PluginDependencySpec

API Documentation:PluginDependencySpec

A mutable specification of a dependency on a plugin.

Can be used to specify the version of the plugin to use.

See PluginDependenciesSpec for more information about declaring plugin dependencies.

Properties

No properties

Methods

MethodDescription
version(version)

Specify the version of the plugin to depend on.

version(version)
Incubating

Specify the version of the plugin to depend on.

Script blocks

No script blocks

Method details

PluginDependencySpec version(String version)

Specify the version of the plugin to depend on.

plugins {
    id "org.company.myplugin" version "1.0"
}

By default, dependencies have no (i.e. null) version.

Core plugins must not include a version number specification. Community plugins must include a version number specification.

Note: This method is incubating and may change in a future version of Gradle.

Specify the version of the plugin to depend on.

plugins {
    id "org.company.myplugin" version libs.versions.myplugin
}